Jump to content

Photo

Bugs,bugs Everywhere

fatal bugs whiteflag

  • Please log in to reply
10 replies to this topic

#1
Luke Ridiculous

Luke Ridiculous
  • 167 posts

unequipped books and somebody raiding me...you guys really need to fix this bug -_- they seem to appear more and more frequently everytime we log in


pic: https://imgur.com/a/3oYUn


  • 5

#2
fadouss

fadouss
  • 21 posts

but the game still good with all those problems :)


  • 0

#3
MostSeriousUser

MostSeriousUser
  • 1 posts

I also reported the disappearing books problem recently and I truly hope that will be fixed, it's a real nuisance.


  • 1

#4
Matt Baker UK

Matt Baker UK
  • 158 posts

sure, there is a loading glitch where sometimes the books unequip themselves but you just re-equip them,

if you're using a perm peak oil when you go to it in the inventory it's slot lock timer can still be running as if it's still equipped,

White Flag is always able to be equipped without a cooldown period,

 

I have encountered this  but it's never resulted in me being raided,

 

when I notice an increase in loading glitches there always seems to be an external cause,

 

I check to see if there's a browser update, I use firefox, click on help. about firefox then check for updates,

and I check to see if there is a flashplayer update,

 

https://helpx.adobe....ash-player.html

 

I don't allow any automated updaters as they have a habit of starting up while you're in the middle of something and hijacking computing resources, therefore I disable all automatic updates and check manually every few days.

 

I use firefox both on Armor & FB, I'm using Win10 and there is a 64bit version of Firefox called Quantum, you may not be automatically offered this when you go to download firefox and might have to seek it out,

 

https://www.mozilla.org/en-US/firefox/

 

with FB Gameroom they seem to have served a mandatory update that's made playing this flash game impossible, it's now software rendered and the cpu is running at 99% constantly, a warning that your graphics card may be unsupported has appeared,

 

I've reverted to playing on FB via my profile page and playing in-browser on facebook.com, not gameroom, this is working fine, you may have to allow 3rd party cookies to some extent to enable the game to communicate with FB and realise you're logged in.

 

I always have task manager running on a Windows pc,  right click the taskbar at the bottom and select task manager, you can watch how much cpu and memory is being used,

 

with Firefox the one to watch is the firefox plug in container, mine is using 500mb when I log in, after a few missions and especially after a few heavy rushes the memory loading of the plug in container will rise, if mine goes over say 1Gb I refresh/reload the game after the mission or before the next,

 

this allows me to avoid flashplayer crashes during missions due to memory overloading, it reduces lag too.

 

I uninstalled all the software on my pc I never used, this dropped my ram usage at idle from 40% to 20%, I've got Intel HD graphics which use the system memory, i.e. ram instead of an embedded graphics memory chip, freeing up ram gives this game more room to do it's thing,

 

I've installed CCleaner  from Piriform, the free version, I regularily run it to clean persistent cookies, temp files and browser caches, not all this gets cleared even if you set Firefox to clear cookies and cache on close down,

 

https://www.ccleaner.com/

 

In CCleaner you can select which cookies you wish to retain, I've kept anything to do with Mozilla, playerio-a.akamaihd.net which is the flashplayer cookie for the game on armor and graph.facebook.com which seems to be needed to play inbrowser on facebook,

 

I've also installed adblockplus with the filter lists: disable malware, easylist, easy privacy, fanboys annoyance list, fanboys social blocking list,

 

https://addons.mozil...-plus/versions/

 

this cuts down on the amount of crap trying to load on the armor page and also gather telemetry etc whilst you're trying to load the game, you do need to add the adblockplus related cookies to your cookie save list in CCleaner and also not select 'site preferences' in CCleaner as this will wipe your filter lists each time you run CCleaner.

 

Armor's homepage got so heavily infested with superfluous stuff recently I even added a few custom fliters :

 

stripe.com
google.com
disqus.com
disquscdn.com

these are in the my filters list under advanced, it helped the Armor page load instantly instead of taking an increasing amount of time whilst all these sites did whatever they do in the background.

 

sometimes after a major game update, like an event for instance, you do actually need a fresh flashplayer cookie, although in Windows 10 flashplayer is integrated in the operating system I've downloaded the appropriate version for Firefox,

 

if you go to control panel in windows there is a flashplayer panel, here you can view and clear site storage, this is where the playerio and graph.facebook cookies live,

clearing these and allowing a fresh version to be loaded can clear loading glitches and bugs too sometimes, you will need to reset your ingame preferences etc,

 

actually within the game there are settings, the cog icon down under the map and notebook,

 

I've found most pc's don't like the static lighting, the dynamic lighting is for turning on and off the flood lights,

 

I turn off gore, tracers, inventory preview, static lighting, 3D sound, anti aliasing and shadows... all to reduce loading on the graphics, this can speed the game up on pc's with limited graphics capabilities.

 

so... like all of this has nothing to do with Con Artist Games and is all to do with browsers, horrible advertising and marketing cookies and the set up of the players personal pc/device,

 

even the servers that host the game aren't in the physical possesion of CAG, they only own the software on them and have to access them remotely, they rely on the hosting service to keep the physical hardware in good order,

 

some of the connection issues in all probability are connected to how the hosts choose to arrange the connectivity of their servers and are parameters that CAG have  to work within,

 

yes there are a few bugs and quirks with this game but it is a very big Flash game, a 'phat game' some might say, I manage to play pretty consistently with relatively few problems by maintaining and optimising my end of the setup, the stuff I can control,

 

I also don't use wifi, I'm using powerline converters to get ethernet to the room I play in, I do occaisionally restart my router, they can mess around too,

 

I've tried using Microsoft Edge and chat just doesn't work properly,

I've tried using Internet Explorer 11 and the mouse scroll doesn't work and mouse movement and clicks cause wierd lags/pauses,

to date I've not got Opera to work satisfactorily, this is a work in progress,

I've no personal experience of Google Chrome, I'm a  bit suspicious of Google these days and tend to avoid their products!

 

sorry this is a monster post,

 

in chat I repeatedly make various observations to users having problems and they often seem to help,

 

here I've tried to put down everything I've discovered in several years of playing in the hope it's helpful to players in improving thier playing experience before going on to ask  Con and the gang to 'do something about it'

 

hopefully some of the stuff above can improve some players gaming experience,

 

BIG FAT DISCLAIMER:  I'm not an IT professional and I've no connection with CAG, these are personal observations based on personal experiences playing this game, if you make changes to your set up do it one step at a time and observe the consequences before going further, look before you leap !

 

 

Con, Sev, please comment if there is any point where I've got the wrong end of the stick or am suggesting something that is prejudicial to the good of the game, I will gladly amend this post under your advice.


Edited by Matt Baker UK, 11 February 2018 - 01:49 AM.

  • 5

#5
Sev

Sev
  • 553 posts

This bug is really annoying and it has honestly had be stumped for a long time.  I have run lots of experinents to try and replicate, but have had no real success. I have also added in a bunch of data dumps to be triggered when books are removed by the server, but it doesn't appear to be getting triggered :/

 

Ifit is happening to you a lot and you can see a pattern please let me know so I can investigate further.



#6
Matt Baker UK

Matt Baker UK
  • 158 posts

Hi Sev,

 

I've had the book unequip a few times,

 

it seems to be one of the interrupted/incomplete loading of the game bugs,

 

you can get:

 

black alliance flag and no boosts showing,

 

or

 

no buildings in the compound and drastically negative morale,

 

or

 

no schemes at all in the crafting menu,

 

or

 

tasks and achieves dissappeared from the notebook,

 

or

 

armor stats on uni's reverted to what they would be on the base purple,

 

all can be fixed by reloading the game except the book unequip where you have to manually re-equip the books but the White Flag cool down to re-equipping is never triggered so you can re-equip it and I'm sure I've seen the slot lockout on Peak Oil still running on the book while it's in the inventory but not in the slot.

 

the most often point the game hangs on loading seems to be 'joined game instance' the loading bar just doesn't move further anymore and the loading icon just spins and spins, if it's doing something it kinda hesitates or stop starts,

 

I know I've got past the main hang point if it starts saying 'initialising server'

 

if my game hangs on loading I just click on the browsers reload current page button and let it try again,

 

once the game has loaded there is an audible click as it switches to the page which will display the compound, if I hear a kinda stuttered double click I kinda expect there to be a misload apparent,

 

if it's a day where there seem to be a lot of hangs on loading there's more of a chance of a misload, it kinda has good and bad days or possibly at times of high traffic, I've no way of measuring this.

 

if when the game is loading the loading bar zips across the bottom of the screen I kinda feel I've got a nice fast, clean connection, a sense of relief that it's going to be allright : D

 

idk if it's a problem making a clean connection with the server and getting the whole uncorrupted game file served to your pc intact or whether it's the ridiculous amount of tracking, marketing, advertising etc cookies that get served with the host page interfering with the data stream on loading,

 

I can't do anything about what happens at the server end but I can block as much irrellevent stuff from my browser page as possible with stuff like adblockplus,

 

 

I must say I don't get that many loading problems but from peeps losing their shiz over it in chat  it seems some get it a lot,

 

I can only guess that my set up is less cluttered with stuff happening while the game is loading or that my ISP gets a cleaner connection to the server than other peeps.

 

maybe if peeps supply their country/region and ISP it might show up a pattern, maybe their browser too,

 

I'm in the UK and my ISP is BT  British Telecom, I'm using firefox quantum,

 

 

idk if in replicating you've tried running a browser that is totally open to all the marketing and advertising cookies and stuff and if you've tried using a vpn to route the connection through different countries and nodes maybe?

 

 

anyway, I know zip about networking and connectivity, I can only wish you the best of luck in your investigations!


  • 6

#7
Sev

Sev
  • 553 posts

Thanks for the feedback.  I think the bulk of what you have described does sound like network issues. 

 

I did some digging and there does seem to be a higher than usual number of load failures between our game servers and the content servers - that could possibly be causing some of the load fails (although it is supposed to recover if it fails)
 

I'll see if there is anything I can do to imrpove things on our end.  I will also raise an issue with our service providers and see if there is anything they can see that may be causing it.



#8
fadouss

fadouss
  • 21 posts

can you make reaward in TD more valuable i stopped doing TD cause of that paying fuel for crap items its not fair 

 

:) 


  • -2

#9
Pro_Tyle

Pro_Tyle
  • 145 posts

Appreciate the work CAG team, for the last few days I've not have those loading freezes anymore. Maybe even some other minute bugs have been squashed too. You people rock


  • 2

#10
Matt Baker UK

Matt Baker UK
  • 158 posts

Hi Sev,

 

just to keep you in the picture, the loading bugs seem to have started happening again,

 

since the new certificates were installed I've had my books unequipped on loading once, black alliance flag and no boosts showing several times, more hangs during the loading process requiring refreshes and a few instances of the screen of static when deploying on a mission,

 

just now I loaded up on FB and got the black flag at first, then by the time the blue tiles had cleared and all the building pictures had loaded the alliance flag and boosts came to life! 

 

I've not seen the black flag 'recover' before, a 1st for me,

 

I've also seen peeps in chat saying their research window is messed up, I've not experienced this one myself and no one has been able to articulate or demonstrate the problem, I did ask if they could post a screen shot via imigr or such like, I've suggested refreshing and it seems to have satisfied them, no feedback on whether it solved it though,

 

ironically, while there was the certificate problem and I'd added your games site to my exceptions the game was playing pretty much faultlessly, loading reliably, no visible problems,

 

this may have been due to the reduced traffic,

 

I just wanted to mention this in case it triggered an idea of a cause and effect in your mind.

 

another crazy thing, totally out of your control, on valentines day on facebook I just couldn't get the game to complete loading, it kept hanging, fb had sent me an animated valentines day post and when I dismissed this post from my home page, so it didn't display itself, the game then was able to load normally,

 

idk if this animated post was coded in a similar way to the game and having it running whilst the game was trying to load was causing some sort of digital kerfuddlement... !

 

anyways, just offfering some feeback to try and head off any growing problem in the future and looking forward to your 6th Birthday celebration!

 

Matt

 

 

update:  strangely since posting this I've not had any further mis loads, I did get grumpy with the facebook page and added further filters to my adblockplus custom list to block facebook graphics,

 

fbcdn.net     seems to have scotched them!  hopefully that's another conflict eradicated!


Edited by Matt Baker UK, 18 February 2018 - 02:56 PM.

  • 0

#11
bossfighter7

bossfighter7
  • 110 posts
This game has a serious bug problem. *sorry for the bad joke* but in all seriousness the bugs are very annoying the game won't work on one of my browsers and I really love this game.
  • 0



Also tagged with one or more of these keywords: fatal, bugs, whiteflag